WEBSITE & DOMAIN SECURITY

WEBSITE SECURITY ON THE INTERNET

When using open source software like Wordpress or WooCommerce, there are vulnerabilities which can be exploited in 3rd party plugins or similar which may compromise the security of your data and website files (corrupted or removed).

The end result of this is your website may become unusable and no one will be able to visit your site pages or make purchases. The general solution for this is to rebuild the site from scratch using whatever usable data is left over. This is error prone and  time consuming and can significantly disadvantage your business.

We’ve developed the following packages to mitigate a hack of your hosting environment. In the event of a hack taking place off-site backups ensure your data is restorable. 

Offsite backups are also useful to roll back undesirable changes to content or data.

The following packages should be considered:

ADVANCED SECURITY
Contact for Price

Advanced package offers comprehensive security and data restoration in the event of a site hack. Key features are the off-site backup which guarantees data safety and site restore in any hack or data corruption.

Off-site/domain data backup. 
Backups to run daily and be recoverable for up to 2 weeks

SSL certificate

Weekly plugin updates

Change default login credentials to secure ones

Wordpress firewall

Disable file editing on website

Limit login attempts

Log out idle users

2FA - two factor authentication

Security question to WP login

BASIC SECURITY
Contact for price

Basic security package offers security for more basic site hacks and simple "on domain" data recovery

On-site/domain data backup - backs up website data to domain (cons are if domain compromised, your data will be non-recoverable, so useful for restoring site edit mistakes etc.).
Backups to run daily and stored for up to 2 weeks recoverable.

SSL certificate - Secures traffic to/from the website from 3rd party interception

1X per month plugin updates - Ensures the latest versions are being run at all times to patch vulnerabilities